Louvre windows not cutting wall when i copy them

Post your discussions and questions about PlusSpec here.

Moderator: Daniel

Louvre windows not cutting wall when i copy them

Postby jwhida » Thu Oct 15, 2015 10:20 am

When i copy a generic louvre window using the window redefine tool, the new window does not cut the wall!
Any ideas ?
Screen Shot 2015-10-15 at 11.04.40 am.png
Screen Shot 2015-10-15 at 11.04.40 am.png (34.77 KiB) Viewed 11068 times
jwhida
 
Posts: 57
Joined: Thu Oct 15, 2015 8:00 am

Re: Louvre windows not cutting wall when i copy them

Postby Dean » Thu Oct 15, 2015 4:10 pm

Hi,

Thankyou for pointing this bug out to us. The window is cutting the wall. What it is not doing is that it is not bringing across the materials.

To fix this use the Window options tool inside of 'Tools for Interacting With Windows', make sure the correct materials are selected and then press submit.

The window will now be fixed and working correctly.

Kind Regards
Dean
User avatar
Dean
PlusSpec Developer
 
Posts: 447
Joined: Tue Mar 18, 2014 8:25 am

Re: Louvre windows not cutting wall when i copy them

Postby jwhida » Fri Oct 16, 2015 6:55 am

Seems like some sort of deeper or additional problem here. I have to force quit Sketchup after following this advice.

Firstly,
When i copy a louvre window using the window redefine tool, and then try to edit the copy in the workaround you suggest, some of the settings shown do not reflect the settings of the copied window. For example the window should have these settings:
‘Attributes: Frame Width’ = 100mm,
’Attributes: Architrave’ = ‘Two sides’
but the panel shows what i assume are the defaults ‘50mm, and ‘One Side’ respectively.
I would expect the edit panel to show the attributes as they are currently set on the window.
So I change them to the correct already implemented settings.

Then when i press SUBMIT, the program hangs until i Force quit Sketchup !!! ( at least 5 minutes, with the spinning wheel and my fans winding up to full speed !!!)

I'm using MAC, OSX 10.10.5 (Yosemite), Sketchup Pro 2015.
Im going to disable all my other handy plugins and see if this still happens

Screen-Shot-2015-10-16-at-7.47.23-am.png
Screen-Shot-2015-10-16-at-7.47.23-am.png (166 KiB) Viewed 11060 times
jwhida
 
Posts: 57
Joined: Thu Oct 15, 2015 8:00 am

Re: Louvre windows not cutting wall when i copy them

Postby jwhida » Fri Oct 16, 2015 7:25 am

The problem of the post-SUBMIT hang actually extends to any louvre window whether it has been copied or not ( I will test other window types next). In other words I have no way to edit an existing Louvre window without causing Sketchup to hang.

I have removed all plugins and extensions except PlusSpec, and restarted Sketchup and the problem persists.
Spinning-Wheel-of-Death-Mac-OS-X-e1344831927846.png
Spinning-Wheel-of-Death-Mac-OS-X-e1344831927846.png (49.89 KiB) Viewed 11058 times
jwhida
 
Posts: 57
Joined: Thu Oct 15, 2015 8:00 am

Re: Louvre windows not cutting wall when i copy them

Postby jwhida » Fri Oct 16, 2015 8:03 am

Testing further ...
Maybe the hang doesn't go forever... but it hangs for a long long time for even a simple case.
Simple test case:
  1. make external clad wall
  2. make generic louvre window on wall
  3. Edit window, but make no changes to the dialog, press 'Submit'
  4. .... Sketchup Hangs for 4 minutes
  5. any key presses or dialog clicks over the past 4 minutes seem to have been queued up and are replayed into sketchup

PlusSpec is only extension installed
2.4 GHz Intel Core i7
AMD Radeon HD 6770M 1024 MB
MAC, OSX 10.10.5 (Yosemite), Sketchup Pro 2015.
jwhida
 
Posts: 57
Joined: Thu Oct 15, 2015 8:00 am

Re: Louvre windows not cutting wall when i copy them

Postby Dean » Fri Oct 16, 2015 4:03 pm

Hi,

I am not exactly sure as to why you are receiving the spinning wheel. I have checked over your requirements and they seem fine. How many gb of Ram does your MAC have?

In the next version you will not have these problems. We are working on version 1.3.5 at the moment.

Kind Regards
Dean
User avatar
Dean
PlusSpec Developer
 
Posts: 447
Joined: Tue Mar 18, 2014 8:25 am

Re: Louvre windows not cutting wall when i copy them

Postby jwhida » Sat Oct 17, 2015 7:47 am

16 GB
jwhida
 
Posts: 57
Joined: Thu Oct 15, 2015 8:00 am

Re: Louvre windows not cutting wall when i copy them

Postby jwhida » Sat Oct 17, 2015 9:02 am

I'll do everything i can to eliminate the possibility this is a problem on my end and report back.
- Disable all other extensions
- Restart computer
- run only bare minimum of applications
any other suggestions

I must say I am very impressed with PlusSpec in most other regards. I just hope there is a solution to this
jwhida
 
Posts: 57
Joined: Thu Oct 15, 2015 8:00 am

Re: Louvre windows not cutting wall when i copy them

Postby jwhida » Mon Oct 19, 2015 6:14 am

I have restarted Sketchup, restarted computer, disabled all other plugins (none of which have caused trouble previously).

Getting up for nice early start to the day. First thing i need to do is adjust the height of a door, and after submitting changes ......... .......................... spinning wheel for 15 minutes before I force quit (see picture 1). So it seems that editing any opening on a wall featuring a louvre causes a hang post submit.

I wish I had more time to try and isolate and document all cases where this is happening but I have a deadline this morning.
My gut feeling is that the louvre window has something to do with it.

The building I am working on is full of louvres (see picture 2), and the only way to work with PlusSpec at the moment is to delete openings and recreate if i want to change something, which has meant hours of extra work and a very disrupted workflow.
DSC_0048.jpg
DSC_0048.jpg (45.94 KiB) Viewed 11044 times

Screen-Shot-2015-10-19-at-7.00.57-am.jpg
Screen-Shot-2015-10-19-at-7.00.57-am.jpg (21.68 KiB) Viewed 11044 times
jwhida
 
Posts: 57
Joined: Thu Oct 15, 2015 8:00 am

Re: Louvre windows not cutting wall when i copy them

Postby jwhida » Mon Oct 19, 2015 4:23 pm

I have moved the hang issue to this thread: https://plusspec.com/forum/viewtopic.php?f=13&t=513
jwhida
 
Posts: 57
Joined: Thu Oct 15, 2015 8:00 am

Next

Return to General Discussion and Questions

Who is online

Users browsing this forum: No registered users and 1 guest